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Overview 
Welcome! This book will explore residential design and construction with guided 
design exercises using Cadsoft Envisioneer.  This book provides an introduction to 
residential design for students. The goal of the manual is to introduce you to Cadsoft 
Envisioneer and residential design. Once you have completed the manual you 
should be able to apply all of the knowledge learned to design your own residential 
design project. 

How this book is Organized 

Each Chapter in the book will include a topic of instruction, sample exercises, a 
review and additional activities. To succeed with the book always start by reading 
about the subject and then trying the sample exercise. The review section will note 
the most important information that you should have retained from the lessons. For 
extra practice try the additional activities listed. 

The sample exercises use Cadsoft Envisioneer and include step by step instructions.  
Cadsoft Envisioneer is a very easy to use design software package that will offer 
your students immediate results.  

Helpful Tips 

Following are some helpful tips so you can get the most out of this book. 

First, commands selected from the menu are separated by an > . For example File > 
Open will indicate to you that you need to choose the File pull down menu and 
then select Open to open a new project.  

If you need to type a value, the value will be indicated in bold font.  For example 5’ 
will indicate that you need to type 5’ on your keyboard. 

We have used several icons throughout the book to draw your attention. Here is a 
brief explanation on what they mean. 

 

Tips suggests alternate procedures. 

 

 Notes offer extra information to explain options or processes further.  

 

Cross References outline that more information may be available on a given 
topic in another chapter of the book. The Cross Reference will point you to 
that section. 

 

Reminder to Save, is just that a timely reminder to save you work! 
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Envisioneer Introduction 
The Hands On Activities throughout the workbook are completed in Cadsoft 
Envisioneer. Cadsoft Envisioneer is a residential design software package that 
Architects, Interior Designers, Builders, Designers, Landscape Architects and many 
other professionals use to develop design ideas and prepare full working drawings.  

Since most of the features in Envisioneer are automated, it is very easy to learn and 
use. You can complete most tasks with a few clicks of the mouse. And with the 
built-in power of Cadsoft’s advanced design technology, you can count on fast, 
accurate, professional-level drawings. 

The information below is a brief look at the interface of Cadsoft Envisioneer to help 
you get started. 

Starting Cadsoft Envisioneer 
1. On your Windows desktop, double-click the Envisioneer 4.5 icon,  

or select Start > All Programs > Cadsoft > Envisioneer 4.5. 
Getting to Know the Interface 
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TITLE BAR 
The title bar runs across the top of the screen. It displays the name of your program, 
the name of the current project, and the name of the current view. 
MENU BAR 
The menu bar is located directly below the title bar. This is where you select 
Envisioneer tools. You can select menu items using either the mouse or keyboard. 
TOOLBAR TABS 
In Model View, four tabs are located just beneath the menu bar: Building, Interiors, 
Landscape and Terrain. In Worksheet View there are three tabs: Draw, Modify and 
Tools. 
These are actually toolbars displayed in tabbed format. They provide you with instant 
access to Envisioneer tools, when you need them. 
BUILDING TOOLBAR 
The Building toolbar contains the tools you need to build a home or any architectural 
structure. It includes tools such as Walls, Doors, Windows, and Roofs. 
INTERIORS TOOLBAR 
The Interiors toolbar contains the tools you need to furnish, decorate and equip the 
interior of your home. It contains tools such as Cabinets, Appliances, Furniture, 
Lighting and Plumbing Fixtures. 
LANDSCAPE TOOLBAR 
The Landscape toolbar contains all the tools you need to create a complete 
landscape plan for the exterior of your home. Tools include Plants, Fences/Gates, 
Decks, and Irrigation. 
TERRAIN TOOLBAR 
The Terrain toolbar contains tools that you can use to design a realistic terrain for your 
model, which is especially important in 3D views. Tools include Hills/Valleys, Slopes, 
Paths, Retaining Walls, and Site Boundary. 

VIEW CONTROL TOOLBAR 
The View Control toolbar contains several essential view-related tools. The toolbar’s 
building location drop box displays the current building location, which is important 
when inserting elements in your drawing. The toolbar also lets you quickly switch 
between 2D view and 3D view, and view and create elevations and sections. A display 
mode button lets you choose the current display type for the view (wireframe, hidden 
line, etc.). The Advanced View Control toolbar also provides instant access to the View 
Manager, where you can create new view windows if you want. 
ZOOM AND NAVIGATE TOOLBAR 
Zoom tools on the Zoom and Navigate toolbar include Zoom In, Zoom Out, Zoom 
Realtime, Zoom Window, Zoom Previous, and Pan. The navigation features on the 
toolbar (Walk Around, Fly Around, Look Around, Slide, Reset Camera) are only active 
when you are in a 3D view. These tools let you change the view in real time using your 
mouse. 
COMMANDER 
The Commander lets you enter precise values for length and direction when inserting 
or editing elements. Directions are based on 0º to the right of the drawing screen, 90º 
at the top of the screen, 180º to the right and 270º is at the bottom of the screen. 
Initially the Commander will look grayed out because it is inactive. It will become 
active when you insert or edit elements. 
VIEW TABS 
By default, each project has two view tabs displayed to start: Standard (a Model View) 
and Sheet 1 (a Worksheet View). These view tabs help you easily switch between view 
windows. If you create new view windows, the tab display updates automatically. 

MODEL VIEW VS. WORKSHEET VIEW 
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When you open a new project, the Standard view window is displayed. This is a 
Model 
View window. It’s where you build, edit and view your 3D model. By default, your 
project also has a view window called Sheet 1. This is a Worksheet View window. 
When you switch to a Worksheet View window, you go directly into 2D drafting 
mode. The drafting mode interface contains a number of different drafting tools that 
help you create professional-looking working drawings. 

SCROLL BARS 
There are scroll bars on the right side and bottom of the drawing area. They let you 
scroll back and forth and up and down in the drawing area. 
CATALOG PANEL 
The catalog panel, located on the right side of the screen, displays the elements 
contained in the program’s Master Catalog, or whatever catalog is currently open. This 
is where you select elements to insert into your drawing. 
STATUS BAR 
The Status bar is located at the bottom of the screen. It displays helpful prompts while 
you are working on your design project. For example, if you are inserting a wall, it may 
display “Pick first insertion point”.  
Drawing Aids 
The lower right of the screen includes a selection of drawing aid buttons that aid the 
user when placing objects into a model. When the drawing aids are listed in black, the 
are turned on. When they are grey the drawing aid has been disabled. Each of the 
drawings aids listed can also be set by going to Settings>Program Settings and 
selecting Drawing Aids in the selection list. 

 
 

 

Collision The program’s intelligent Collision Control feature prevents objects from 
being inserted where they do not fit. If you try to slide an object into an area that it is 
too small, the object will flip or prevent you from moving it into the area. By default, 
Collision Control is on, but you can turn it off if you want more flexibility with object 
placement. 

Ortho The Ortho feature restricts your cursor movement to 90-degree angles when 
you are inserting elements. This can be especially helpful when drawing elements like 
walls. 

Grid A drawing grid is simply a set of horizontal and vertical lines that can help you 
orient objects to one another. By default, the spacing between grid lines is 1’, but you 
can change this if you want. You can also control the color and style of the grid. 
Note that the drawing grid is a visual aid only, and will not be included in printouts. 

Angle Snap When the Angle Snap feature is turned on, your cursor snaps to specific 
angles when rotating an element. If you set your snap angle to 10º, for example, your 
cursor will snap at 10º intervals as you rotate the element. By default, the Angle Snap 
is on and is set to 15º.  

The drawing aid is on 
when it is black. 
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Program Settings 
Envisioneer offers many options to customize the interface to suit individual 
preferences. There are two different types of settings available in Envisioneer: those 
that control how the program works and how the screen looks, and those that affect 
the actual model.  
Most program-related settings are found in the Program Settings dialog. Let’s look at 
these now. 
1. Select Settings > Program Settings. Notice the list of setting types in the left 
pane. 

 
2. In the left pane, select Units of Measure. 

3. Click on the Precision drop box below the Units drop box, then select the full 
feet and inches option (#’-#”). This will make drawing walls quick and easy in the first 
exercise. 

 
4. Click OK. 

Building Locations 
The most important model-related settings are your Building Locations, which 
determine the heights and levels of your walls and other elements. 
1. Select Settings > Building Locations. 

Program Settings 
determine how the 
screen looks, and how 
the program works. 
 

Select a level of 
precision
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When you insert an element in your drawing, it is inserted on the current building 
location. It is important to define your building locations before inserting elements, 
since building locations are the key to organizing elements and inserting them at the 
correct height. When you define building locations, you are basically doing two 
things: 
• Setting the wall height for each floor (level) in your model 

• Specifying where each floor is positioned relative to the ground (zero) 

 

 
 

 

Number. A reference number 
for the location. 
Name. The location’s name 
(e.g. Ground Floor). 
Floor Level. Height of floor 
above ground level (0). 
Head Height. Height of tops of 
windows relative to the floor 
level. 
Ceiling Height. Height of 
underside of ceiling surface 
relative to the floor level. 
Wall Height. Physical height of 
the walls on the location. 



 

| Residential Design  Page 7 of 59 

Residential Design  
 

OBJECTIVES 
In this section you will cover the following topics: 

• Comparing contemporary and traditional design 

• Historic Design Review of Georgian Colonial, Gothic Revival, Frank LLyod 
Wright’s Prairie House and Art Deco residential designs in North America 

• Drawing walls in Cadsoft Envisioneer 
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History of Residential Design in North America 
There have been many different styles of residential design throughout history. Styles 
are developed from materials, building techniques and regional needs. Each period 
style usually has one distinctive quality that one instantly recognizes of a house that 
has been either built during that time period or influenced by that style. From 
Neolithic architecture circa 10000 BC to the current “blobitecture” of the year 2000 
design has progressed due to new building materials, techniques and personal needs 
in a residential space.  

Generally speaking styles of design can be broken down into two major categories: 
Traditional or Contemporary.   

A traditional style is influenced by history. 

A contemporary style is focused on modern materials and methods and has little to 
no influence from history.  

This chapter will focus on 4 styles, 2 traditional and 2 contemporary, that have had a 
great influence on North American architecture. The styles are distinctive because of 
the materials, roof styles, ornamentation and shape.  

Georgian Colonial Design 
The Georgian style of Architecture was prevalent in Europe in the 1700’s and was a 
very balanced style of architecture with ornate details that were a combination of 
Italian Renaissance, Greek and Roman influences. In North America, colonists were 
very impressed with the style and strove to imitate it but choose local materials such 
as clapboard siding and less ornate details. This new style was dubbed Georgian 
Colonial. This residential style is most recognizable because of the focus on symmetry 
with the front door being the center focal point with the most ornate detail.  A 
Georgian colonial style home is all about proportions. Each window is exactly placed 
in the center of a room and the window size itself is in direct relation to the size of the 
room that it is installed. A chimney is typical on each end of the house. After the 
Revolution this style lost its popularity and revival styles became the fashionable 
choices. 

Georgian Colonial is a traditional style of residential architecture. 
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Georgian Colonial Sample 

Materials: Clapboard siding.  

Roof Style: Gable Roof, low slope, little to no 
overhang. 

Ornamentation: focal ornamentation 
around the door 

Shape: is very important to this style as it is 
very proportional. Symmetrically placed 
windows that are installed in the center of a 
room and are proportional to the size of the 
room. A true Georgian Colonial will have 
exactly 5 windows across the front of the 
house on the second floor and 2 windows 
on each side of the front door on the main 
floor.  

 

Gothic Revival 
From 1840-1880 many impressive homes were built throughout North America that 
were heavily influenced by the gothic style of architecture found in medieval 
cathedrals throughout Europe. This style had many different material usages 
depending on the availability ranging from masonry, stone and timber siding.  The 
most distinctive characteristic of this design style is the steep roof pitches with a focal 
gable with a steep peek. Windows were tall and arched and flanked the ground floor 
porch that wrapped around the house. The millwork on the interior and exterior was 
elaborate or at the very least to a large scale and there was plenty of it around 
doors, windows and columns. The downfall to this design style is that it took many 
skilled tradesman to complete it properly thus adding to its expense and time to 
complete so it lost its popularity over time. Gothic Revival is an example of traditional 
residential architecture. 
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Gothic Revival 

Materials: Clapboard siding, stone brick 
depending on where the house was built.  

Roof Style: Steep gable roof with a wrap 
around porch on the main floor. 

Ornamentation: Generous amounts of ornate 
wood work detailing on columns, around 
windows and doors and throughout the 
interior. 

Shape: Gothic Revival is tall in shape in the 
windows and roof pitches. The shape of the 
overall building various and is not 
symmetrical. 

 

Frank Llyod Wright’s Prairie House 
Frank Lloyd Wright has had a dramatic role in the development of modern 
architecture. His work from 1900-1917 is a dramatic opposite to the Gothic Revival 
styles that had been so previously popular.  The “Prairie Houses” of this time were 
dressed in low sloped roofs that had large overhangs. The materials were unfinished 
and natural that gave his designs an organic influence.  The designs were said to 
complement the landscape and not compete with it. The “Prairie House” is the first 
example of open floor plans that continue to be popular in residential design.  The 
interior of a Prairie house is the main architectural feature, the flow of one room to the 
next and beyond to the exterior. Frank Lloyd Wright designs are examples of 
contemporary residential architecture. 

Prairie House Example - Taliesin's drafting 
studio by Frank Lloyd Wright. Picture by K. 

Murphy. 

Materials: raw natural materials that 
compliment the surrounding landscape.  

Roof Style: low slope roofs with large 
overhangs. 

Ornamentation: only ornamentation that 
would compliment the landscape done in 
natural materials. Stone feature walls or 
wood columns.  

Shape: Sprawling bungalows with open 
concept plans. 
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Art Deco 
In the 1920’s design was all about modern methods and materials. After the 1925 
Exposition Internationale des Arts Decoratifs et Industriels Modernes in France people 
were drawn to man made materials and the new style derived its name from this 
event: Art Deco. Smooth man made finishes, flat roofs and geometric cut outs are 
characteristic of this simplistically elegant design era. It offered a fresh new modern 
take on architecture after the oppressiveness of the World War. Art deco is an 
example of contemporary design. 

Art Deco 

Materials: Smooth man made materials: 
metal, glass, stucco were prominent. 

Roof Style: Flat roof 

Ornamentation: Geometric shapes and 
the sunburst pattern were prevalent in 
design. 

Shape: Geometric shapes are very 
important to this design in both the walls, 
windows, doors and any ornamentation. 

 

 

As design has progressed throughout history many new styles of architecture have 
developed because of the cross usage of materials and building techniques brought 
upon by international travel. Many styles have enjoyed “revivals” and cross used with 
other popular styles. It therefore becomes difficult to determine an exact style as 
many different “labeled” styles have been intermixed.  A more generic label of 
“contemporary” or “traditional” can be applied to residential design styles. 

Hands On Activity I - Residential Design History 

For You to Try – This exercise requires the use of Cadsoft Envisioneer 
Cadsoft Envisioneer includes many sample homes in their library that we will use in this 
exercise to understand the difference between contemporary and traditional design.  

Label the following residential buildings as either Contemporary or Traditional.  Can 
you go further and identify individual design influences in details and their period in 
history? Explain why you have made the design choice.  

1. File >Open Samples. 

2. In the Open dialog box select Sample 1.bld and click Open.  

3. A plan view of a house will appear. Let’s take a look at it in a 3D view. Select 
View>3D Camera Views>Front View. 
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4. The front of the home will appear in a 3D model.  

Looking at the 3D view, write down the design styles that have influenced the model.  

5. File>Close. 

6. Repeat this for all of the Sample models included in the samples directory. 

Hands On Activity II - Residential Design History 

For You to Try – This exercise requires the use of Cadsoft Envisioneer 
Next we will begin laying out the shell of a building that has characteristics of a 
Georgian Colonial style home. We will build upon this home throughout the workbook 
as a constructive exercise in each unit and add influences from other design eras as 
well. 

Refer to the Envisioneer Introduction in the Overview unit for help on how to get 
started with Cadsoft Envisioneer. 

You can draw walls by simply pointing and clicking with your mouse.  By default, 
every exterior wall in the catalog is defined as a composite. A composite wall is a 
structural wall and veneer wall put together, with an air space in between. 

Perimeter walls are drawn on center in Envisioneer. Using the Insert by Boundary 
option, you can insert perimeter walls to the outer veneer, or interior wall dimensions. 

1. File >New. 

2. Make sure your ORTHO is on. If it is on, it appears enabled on the status bar below 
the drawing area. If it is not enabled, just click on it to enable it. 

 

3. Look at the View Control toolbar and ensure the current location is the Ground 
Floor. 

 

4. Select Insert > Walls, or click the Walls button on the Building toolbar.  

5. In the catalog panel, select the 2x6 Framed Horizontal Siding Wall element 
in the Exterior Walls category.  

6. Position your cursor in the drawing area, then right-click 
and select Insert by External Boundary.  

NOTE: This option lets you draw a wall outline, and then offset the walls from that 
baseline. This provides precise control of your wall measurements. By default walls are 
drawn by their centerline, the External Boundary command gives you control over if 
the dimensions entered are to the centerline, exterior or interior finishes. 

7. Select a point in the lower left corner of the drawing area. 
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8. Move your cursor to the right and type 34’ and press Enter. 

9. Continuing from the endpoint of the first wall, move your mouse upward (in the 
90° direction). Notice the Direction in the Commander reads 90°. Notice also that 
the Distance changes as you move your cursor. 

10. Type 30’ and press Enter. 
11. Referring to the diagram below, continue inserting walls in sequence by typing 

their lengths.  
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12. When all the walls are finished, right-click and select Finish. 

 
13. In the External Boundary dialog, make sure the Outer Face of Veneer option is 

selected, and then click OK.  

 
 

14. File>Save. 

Note: If drawing composite walls, the veneer appears only if the walls connect to 
form a closed layout. Otherwise, only the structural wall is displayed. If you have 
chosen a composite wall and only the structural wall is showing, check your corners 
to ensure that you have formed them properly. 

 

History of Residential Design Review 
1. Residential design has been influenced by: 

a. Building materials available to regions. 

b. Design requirements based on social behaviours. 

c. Building methods. 

d. Personal taste. 

2. To determine the era that a house was designed look at the following key factors: 

a. Materials 

b. Roof Style 

The blue lines represent 
the exterior veneer and 
the brown lines represent 
the structural wall. 
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c. Ornamentation 

d. Shape 

Envisioneer Review 
1.  

Design requirements 
 
 
Additional Activities 
For more practice at recognizing different architectural styles, try the extra activities 
below. 

1. Using Cadsoft Envisioneer, layout the external walls for an Art Deco home. 

2. Take a walk through several different subdivisions. Depending on the year the 
subdivision was completed the architectural styles may reflect various styles. Take 
pictures of different houses and try to determine their age and style of 
architecture. 

3. Divide into groups and each group study a separate residential design style. 
Those covered in the workbook and other styles of interest. Find examples of the 
styles and further descriptions that depict the style. 



 

| Room Requirements  Page 16 of 59 

Room Requirements 
 

OBJECTIVES 
In this section you will cover the following topics: 

• The functions of different rooms in a home 

• The space requirements of rooms 

• The co-functions of different rooms and their best positions 

• Drawing interior walls in Cadsoft Envisioneer 
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Room Functions 
Each room in a house has a specific function and each function in a home has 
specific space requirements. As you are planning a home you must take a look at the 
specific needs of the owners and the associated space requirements. Then combine 
the rooms to create the home.  

Let’s take a closer look at the individual rooms and their requirements.  

The Kitchen 
 

 

 

 

 

 

The Kitchen has an obvious function of a space to store and prepare food but now it 
has also developed a social function as well. Kitchens have become the center point 
of a home, where the family meets, eats and entertains. All of these factors must be 
taken into consideration when laying out a kitchen space. 

1. How many people are in the home? Space requirements when designing 
eating areas in the kitchen. 

2. Who prepares the meals? If there are multiple “chefs” in the house than space 
consideration in the kitchen area must accommodate multiple people. 

The key factor when designing a kitchen is adequate workspace that is accessible. A 
kitchen should leave a 36”-42” working aisle in front of the counters so that one 
person can work at the counter and others can walk freely in the kitchen without 
causing interruption.  

See Interior Design chapter for more information on laying out a kitchen. 

 
The Living Room 
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The Living Room, formally known as the Parlor, is a room where guests are 
entertained. The living room needs to accommodate furniture for people to sit, relax 
and converse comfortably, so depending on the size of the home and the number of 
guests that the occupants entertain this room can change in dimensions.  In the living 
room you must also consider the architectural elements in the room: windows, 
doorways, fireplaces.  These elements and their placement in a room can have a 
large impact on the design of the room. Traffic must flow through the room but it 
should not interrupt the designated entertaining areas. A fireplace is a great focal 
point in a room, but again, it shouldn’t take over the room so that the purpose of the 
room; to entertain, sit and relax, is interrupted. 

Designing a living room is a two part process; 

1. Make a list of the functions of the room that are important to the occupants.  

i. Is it a room strictly for entertaining guests? If so it needs to be an 
impressive space with adequate seating for the size of crowd normally 
entertained.  

ii. How many people are in the family? This will effect seating requirements 
in the room 

iii. Will this room hold a television? This will affect the size of the room and 
the layout of the space.  

2. Make a list of the architectural elements of the room. 

i. Doorways for access to the room 

ii. Windows to add light and views to the room 

iii. Fireplaces and entertainment units add a focal point to a room but also 
can break up a room and require thoughtful consideration for 
placement.  

Remember, one of the most important functions of the living room is a place to sit 
and talk. Leave enough space in the room so furniture can be adequately arranged 
in the room for this purpose without the interruptions from architectural elements.  

The Sleeping Areas 
 

 

 

 

 

The Bedroom has two essential tasks; a place to sleep and storage of clothing and 
personal belongings.  
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What is important to remember about a bedroom is what is stipulated by the local 
building codes. Since this is a sleeping area, careful consideration should be made in 
relation to the size of the windows and the size of the room.  All bedrooms must have 
a proper means of egress in case of fire and have a stipulated minimum room area 
as laid out by local building codes. Check local building codes for size requirements 
in your area.  

Consideration should also be made in the size of the furniture that will be placed in a 
room. Below is a chart of average bed sizes in North America (countries around the 
world have different sizing standards). Consult the chart to ensure that the bedroom 
space designed is large enough to hold the bed and storage furniture. 

Crib Twin Double Queen King 

28”x 52 39”x75 54”x75” 60”x80” 76”x80” 

The Bathroom 
 

 

 

 

 

Even though it is the smallest room in the home, the bathroom involves the largest 
number of professionals to install. A plumber, tiler, electrician, flooring installer, painter 
and cabinet installer are just a few of the skilled tradesman required, which is why the 
bathroom is one of the most expensive rooms, based on cost per square foot, that 
you will spend in a home. Thousands of dollars in fixtures are found in as small as 50sq. 
feet.  

The necessities of a bathroom include sink, toilet, tub and shower. New homes, 
however, are being built with special attention given to luxurious bathrooms with 
multiple sinks, toilet and bidet, separate tub and shower stalls. 

Ensure that you give consideration to materials when designing the bath. Bathrooms 
are prone to high condensation and water. Design the space with materials that are 
resistant to moisture and mold. Ventilation systems should also be installed to alleviate 
the problems moisture can cause.  

Storage 

An integral part of any home is storage space.  

INSERT TEXT 

Creating a Floor plan 



 

| Room Requirements  Page 20 of 59 

Certain rooms function best in close proximity to others. Plan a zone for activities done 
in each room: cooking, dining, entertaining, media viewing, conversation, play, and, 
importantly, unobstructed passageways through the house that won’t disturb 
ongoing activities. Now look at how these rooms function together.  

The kitchen and dining room, as an example, should be close together so food can 
be served in an efficient manner. You want an area in your home for entertaining but 
you also want to offer personal space. Try to arrange the rooms used for entertaining; 
living rooms and dining rooms away from spaces that will be used for the families own 
personal space; bedrooms, family room.  

Depicting Walls in a Floor Plan 
To create a floor plan you must depict the layout of the walls looking down upon the 
house from above. The walls are drawn to scale showing the actual width of the wall. 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

  
 
Hands On Activity - Creating Rooms in a Floor Plan 

For You to Try – this exercise requires the use of Cadsoft Envisioneer 
We will now insert several interior walls in our model to create interior spaces using the 
following insertion methods: 

• Point-and-click method 
• Insertion Offset option 
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• Copying existing walls 
 

Drawing Walls Using Your Mouse 

1. Select Insert > Walls, or click the Walls button on the Building toolbar.  

2. In the catalog panel, select the 2x6 Wood Framed Wall element in 
the Interior Walls category. 

3. Move your cursor onto the drawing screen area. Place your cursor near the 
intersection enlarged on the diagram below. As you move your cursor 
towards the intersection the Object Snap drawing aid will detect the walls 
and snap to them. Left click to start drawing the wall. 

NOTE: The snap will ensure that you create a clean intersection. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

TIP: To draw straight walls ensure the ORTHO drawing aid is on. If you want to 
draw walls on an angle, ORTHO should be turned off. For this lesson ensure 
ORTHO is turned on. 

 

The Object Snap will detect 
the intersection and your 
cursor will appear with a 
circle and X. 

B 

B 
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4. Move your cursor downwards. Its length is shown as you draw the wall. 
Move your cursor down to the perpendicular wall below (marked B in the 
diagram above) and left click in the exterior wall when the object snap 
cursor appears again.  

The first interior wall is drawn. 

Drawing Walls Using the Insertion Offset Option 

Now we’re going to draw some walls using the Insertion Offset option, which lets 
you start a wall a specified distance away from the endpoint of an existing wall.  

1. With the Walls tool still active, right-click and select Enter insertion offset. 

2. In the Enter insertion offset dialog, type 12’, then click OK. 

 

 

 

 

 

 

 

 

 

3. Position your cursor inside the left exterior wall as indicated in the diagram 
above. When the 12’ dimension line appears from the top, left click. 

4. Your cursor will jump to the 12’ position. Move your cursor to the left and left 
click inside the perpendicular interior wall.  

5. Right-click and select Enter insertion offset. 

6. In the Enter insertion offset dialog, type 8’6”, then click OK. 
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7. Position your cursor inside front exterior wall as indicated in the diagram 
above. When the 8’6” dimension line appears, left click. 

8. Your cursor will jump to the 8’6” position. Move your cursor upwards and 
type 17’ and press ENTER. (The distance appears in the Commander’s 
Distance edit box as you are typing.) 

9. Move your cursor to the right and left click when the object snap appears in 
the perpendicular exterior wall.  

10. Right click and select Finish. 

Creating Walls by Copying Existing Walls 

Walls can be copied to create new walls. You can click and drag the copy to a new 
position, or use the Commander to specify a precise move distance and direction. 

1. Click on the new wall you just created. 
2. Right-click and select Duplicate. The Drag to new position prompt appears 

on the status bar. 
3. Click a point on the wall. A copy of the wall is now attached to your cursor. 

Holding the left mouse button down, pull it downward. Watching the 
distance value in the Commander when it is approximately 5’ release the 
mouse button. 

4. A copy of the wall is created. 
5. Dimensions will appear to place the new wall from the original and the wall 

below. Left click on the upper dimension.  
6. In the Edit Dimension dialog box, type 5’ and click OK. 
7. The wall will move to be exactly 5’ away from the wall above.  
8. File>Save. 

 
Spatial Planning Review   

• Each room in a home has a specific function and those functions require a 
specific amount of space.  

• Certain rooms function best in close proximity to others. A home is “functional” 
if the rooms have been laid out in an efficient manner. 

• When designing a floor plan remember to designate areas for entertaining 
(dining rooms, living rooms) and distance those areas away from the areas for 
personal space (bedrooms, family rooms).  

Additional Activities 
Understanding the space requirements for a house is a very critical design step. Take 
the time to do these additional activities  
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1. Measure the rooms in your own home. Layout out the rooms in Cadsoft 
Envisioneer. Move the walls around to form new spaces and see if you can make 
the home more functional.  

2. Review several floor plans from a home plan book. Rate the designs on their 
functionality. Did they group the entertaining and personal spaces adequately? Is 
the dining room close to the kitchen? Is there too much wasted space used in 
hallways? 

3. Visit a kitchen design studio. Speak with the designer to obtain more tips on 
kitchen space planning. 
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Materials and Methods 
As time has progressed, so have the materials and methods that are used in 
residential construction. Today homes are not merely constructed to provide basic 
shelter but also engineered to make a home environmentally friendly by limiting the 
resources required for the home. This chapter will offer an introduction to the various 
materials used to build a home and the methods of construction.  

Wall Construction 
Simply stated, walls are used to enclose and define living spaces. A wall can be used 
for structural purposes to support the floor and roof structure above or it can simply be 
a partition to divide a space. If a wall is a structurally supportive wall it will be specially 
designed to ensure that it can carry the load of the floors and roof above as well, in 
some zones, wind and earth quake forces.  

Exterior Walls 

Exterior walls protect the interior conditioned space of a home from the surrounding 
environment. The materials used in the wall system should be durable to offer 
protection from the sun, rain, snow and wind and also stop the transfer of cold and 
hot air and moisture through the wall, going in either direction.  To do this walls must 
be well insulated and offer a protective exterior cladding that is water resistant and 
an internal membrane that stops the flow of air through the wall. 

When building a wall you must think of all materials within the wall as a “system” that 
work together. Let’s look at the individual materials in brick and stud wall construction.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Exterior Cladding 
Air Space 
Building Paper 
Sheathing 
Structural Supporting Element 
(stud, block wall, post) 
Insulation 
Vapour Barrier 
Interior Finish 
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Exterior cladding is the first line of defense a wall system has against the elements. 
Ideally it is water resistant and aesthetically pleasing. Examples of exterior cladding 
include: brick, stone, stucco, vinyl siding, wood lap siding, board and batten, logs and 
concrete. There are many more options that have developed over time as materials 
and building methods evolve. 

 

 

 

 

 

 

 

 

An Air Space is used for the inevitable penetration of water. The air space allows 
water that penetrates through the masonry cladding in a wall system to flow down 
the air space and exit through weep holes and flashing that has been installed.   
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Building Paper is a type of water resistant paper that works as a backup barrier in a 
wall if water does penetrate past the exterior cladding. Wind-driven rain and moisture 
can saturate walls, creating a breeding ground for mold, mildew and wood rot. The 
building paper works as a defense line to prevent damage from moisture. It also stops 
airflow through a wall in both directions because the paper is dense. Airflow through 
a wall can create warm or cold spots in a home decreasing the comfort level. There 
are many different types of building paper manufacturers do an internet search to 
research the different types available. 

Sheathing adds shear strength to a wall system by binding the studs in a wall together 
so they work together as a unit. It also provides a nailing surface for exterior wall 
cladding materials such as siding.  

Structural Support Element such as studs or masonry blocks provides the main 
structural support in a wall system. Spaced in regular intervals the studs in a wall 
system provide vertical stability and in a supporting wall support the floors above. In 
North America the most popular residential construction methods are stud wall 
construction or block wall construction but there are several different types of 
structural wall systems. Some are pre-manufactured in controlled environments, 
where others are constructed on site. Do some research on Insulated Concrete 
Form (ICF’s) wall, Adobe Wall construction, Straw Bale Construction as alternative 
supporting wall construction.  

 

 

 

 

 

 

 

 

 

 

Insulation is used to stop the transfer of cold or hot air in either direction in a wall 
system. Different types include batt, foam, loose fill, rigid or blanket and each type is 
used depending on the type of wall construction. Insulation is rated for the amount of 
resistance (R value) of the flow of warm or cold air through the insulation material. The 
higher the R value the greater resistance of cold or warm air transfer through the 
material.  

NOTE: Green Building is focused on increasing the level of efficiency in a home so it 
uses fewer resources. By decreasing the level of heat transfer through a wall system, 

Block Wall 
Construction 

Stud Wall 
Construction 

Concrete 
Block  

Stud  
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less energy is required to heat/cool a home. There are many ongoing, innovative 
research projects that are focused on Green Building like new insulation techniques to 
decrease heat transfer.  

The Vapour Barrier has a key role in the wall system by stopping the flow of moisture 
from inside a home to the wall system. Nothing is more damaging to a wall system 
than the presence of water which can destroy the wall system materials. Vapour 
barrier is placed on the warm side of a wall and stops moisture from escaping from 
the home into the wall system. The vapour barrier is a continuous application of 
impermeable material fastened directly behind the interior finish material. The most 
common vapour barrier material used is polyethylene sheets.  

Interior Finishing materials are used for aesthetics and to protect the wall system from 
damage caused by every day living in the inside of a home. Drywall, gypsum board, 
cement board, lath and plaster and wood paneling are a few common materials 
used. They provide a smooth finish for painting or wall paper hanging so home owners 
can personalize the space with various colour finishes.  

Interior Walls 

Interior walls divide the interior of home into rooms and can also have structural 
properties to support the floor and roof loads above.  Walls provide privacy in rooms 
both visually and acoustically and walls are also used to chase mechanical ductwork 
and electrical wires throughout a home.  

 

 

 

 

 

 

 

 

 

 

Foundations  

Foundations are the most integral part of the entire house construction. They carry 
loads from the house above, interact with the surrounding soil conditions and create 
a solid structure to build upon. Foundations can be constructed from a variety of 
materials, the most common being concrete and masonry block. Whatever material 
is used, it is vital that the foundation system be water resistant and of a strong durable 
material that can withstand the pressure of the subsequent loads from the house and 
the surrounding environment. Surrounding soil puts pressure on the walls and in settling 

Interior Wall 
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can cause severe damage to a foundation system.  Houses can be supported on a 
Foundation wall system, a monolithic slab or on piers. 

Footings 
Footings transfers the weight of a foundation wall and loads above to the soil below. 
It is, generally, 2 times wider than the foundation wall to spread out the load. 
 

 

 

 

 

 

 

 

 

 

 

 

Foundation Wall Systems 

When using a foundation wall system there are four types of basements that can be 
created as a result: crawl space, standard, walkout and daylight.  

In a Crawl Space situation the footings are placed just below the frost line, leaving the 
space below the ground floor too low to be usable.   

Standard basements have useable living space but are not accessible by the outside 
and most of the height of the basement walls are below grade.  

Daylight basements have useable living space with one or more walls exposed, and 
are typically built on hillsides.  

 

 

 

 

 

 

The footing transfers 
the load above out to 
the soil. It is usually 2x 
(or more) wider than 
the foundation wall 
above. 

Soil around the 
foundation plays a 
significant role in the 
type of foundation 
system used. Soil, and 
its movement, can put a 
great deal of pressure 
on the foundation. 

The design of the 
foundation wall is 
important as it has to 
be water resistant, 
carry the load of the 
structure above and 
restrain the soil 
material around it. 

Daylight Basement 
with the foundation 
wall exposed. 
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Walkout basements have useable living space and have access via an exterior door 
and staircase to the outside. 

 

 

 

 

 
 
 
 
 
 
 
 
 
 
Montolithic Slabs 
In warmer climates a full foundation system is not required as there is no frost line or it 
is insignificant. A concrete slab can be poured right on grade with a supporting 
footing beneath it. When the footings and slab are poured together it is called a 
monolithic slab. 
 

 

 

 
 
 
 
 

 
 
 
Hands On Activity-Creating a Second Floor & Foundation 

For You to Try – This exercise requires the use of Cadsoft Envisioneer 
Once you have created your ground floor exterior walls, you can easily add 
more levels to your design using the Duplicate to Locations tool to copy the 
ground floor walls to alternate locations. 

1. File>Open. 

Monolithic Slab 

Walkout Basements have 
a door for access to the 
finished basement. 
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2. Select the file created in chapter one. 

3. Select Edit>Select All. 

4. All of the walls will be selected. Right-click and select Duplicate to Locations, 
or select Edit > Modify Elements > Duplicate to Locations. 

5. In the Duplicate to Locations dialog, select the Second Floor. 
6. Click OK. The walls are copied, and you now have a new story. 
7. Repeat the process and copy the walls to the Foundation location. 

8. In the lower right of the screen, change the location to the Foundation 
location. 

 

 

 

9. Click one of the interior walls, then Shift+click to select the remaining interior 
walls. 

10. Right click and choose Delete. 

NOTE: You will notice that you can still lightly see the ground floor walls above. 
When a particular location is current, elements on all other visible locations are 
dimmed. This makes it easier to insert and edit elements on the current location 
while being aware of the other locations above and below and their structural 
placement.  

11. Select Edit>Select All. 

12. All of the exterior walls on the Foundation location are selected, right click 
and select Replace. 

13. In the Catalog Access dialog box, select the Foundation Walls group and in 
the Walls list below, select the 10” Concrete Wall and click OK. 

14. The walls on the Foundation location have now been replaced with 
concrete foundation walls.  

TIP: As an alternative to duplicating an entire location, once you have created 
your ground floor exterior walls, you can also draw the layout for the second 
floor or foundation just like you did to create the ground floor, using the 
dimmed locations as a guide. 

15. Select Insert>Footings>Strip Footings Attached to Walls. 

16. The catalog panel will update with Strip footing elements. Select the 
Rectangle Strip Footing group and in the Strip Footing list below, right click 
and select Add Element. 
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17. The Strip Footings dialog box appears. In this dialog box you can describe a 
new footing to add to the catalog. This will be a permanent addition to the 
catalog so future projects will have access to it as well. 

18. In the Properties list, click in the edit box beside dy1 and type 8”. 

19. Edit the dx1 value to read 20”. 

NOTE: With the Auto Name feature checked at the top of the dialog box, the 
Name of the footing will update as you change the properties. 

 

 

 

 

 

 

 

 

 

 

20. Click OK and the new strip footing will be added to the catalog.  

21. With the new footing selected move the cursor onto the drawing screen 
area and left click inside one of the foundation walls.  

A dashed footing will appear around the wall.  

22. Repeat for all of the walls. Right click and choose Finish. 

23. File>Save. 

NOTE: An additional support system (beams and columns) will be created later 
in the book to support the floor above.  

Insert new values for the 
thickness and width of 
the footing. 

The Auto Name feature 
will create a name for the 
element based on the 
property values inserted. 

There are many different 
shapes of footings. Left 
click on the type that 
suits the construction 
project. 
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1. Switch the location to the Second Floor. 

 

 

 

2. Referring to the diagram below, left click on wall A. Dimensions will appear 
in relation to the walls parallel to it.  

3. Left click on the dimension above the room. 

4. Type 14’ and click OK. 
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Creating Walls by Duplicating 

 

 

 

 

 

 

 

 

1. With that wall still highlighted, right click and select Duplicate. 

2. Select a base point for the copy movement. Typically you would select one 
of the element's grips, but you can click anywhere in the drawing. The base 
point is simply a reference point used to define the move distance. 

3. Moving your mouse downwards, drag a copy of the wall. When the 
onscreen dimensions read approximately 5’ release the left mouse button. 

4. Click on the onscreen dimension above the new wall.  

5. Type 5’ and click OK.  

The wall is now exactly 5’ from the original wall.  

6. Click on wall B, as depicted in the diagram above.  

The wall will highlight and dimensions will appear to lock its position in relation to 
the parallel walls next to it. 

7. Click on the dimension above wall B. 

8. Type 2’6” and click OK. 

9. The wall moves closer to the wall above it.  

Lengthening and Shortening Walls 

1. Click on the Wall marked C in the previous diagram. 

C 

Create this wall 
by duplicating 
wall A. 

A 

B 
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2. The wall highlights and grips will appear. The grips define the middle and 
endpoints of the wall.  

3. Move your cursor towards the grip on the top end of the wall. As you hover 
your cursor over the endpoint, the cursor will change to indicate it is ready 
to stretch the wall.  

 

4. Hold down the left mouse button. 

5. Stretch the wall up to the exterior walls above and release the mouse 
button.  

 

 

 

 

 

 

 

 

 

 

 

 

6. Referring to the diagram above, select the wall marked D. 

7. Right click and choose Duplicate. 

8. Holding down the left mouse button, drag a copy of the wall to the left.  
Release the mouse button when it is approximately 4’ away to create the 
new wall. 

9. Left click on the onscreen dimension to the left of the new wall.  

10. Type 7’ and click OK. 

11. Click on the wall labeled E in the previous diagram. 

12. Right click and choose Duplicate. 

D 
E 
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13. Holding down the left mouse button, drag a copy of the wall to the right.  
Release the mouse button when it is approximately 5’ away to create the 
new wall. 

14. Left click on the onscreen dimension to the left of the new wall.  

15. Type 5’6” and click OK. 

Creating Walls Using the Insertion Offset Option 

1. Select Insert > Walls, or click the Walls button on the Building toolbar.  

2. In the catalog panel, select the 2x6 Wood Framed Wall element in 
the Interior Walls category. 

3. Move your cursor onto the drawing screen area and right click and select 
Enter Insertion Offset. 

4. Type 11’ and click OK. 

5. Place your cursor along the interior wall as indicated in the diagram below. 
When the 11’ dimension is in place left click to start drawing the wall from 
that position. 

6. Move the cursor to the right and left click in the opposite interior wall. 

7. Right click and choose Finish. 

8. File > Save.  
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Doors 
Simply stated,  

 

Depicting a Door in a Floor Plan 
When depicting a door on a floor plan you show the door and the swing that it will 
take from its open to close position and the framed opening that it makes in the wall. 
This allows the person viewing the floor plan to visualize the size of opening, the 
direction of the door swing and any obstructions that may affect the door when it is 
opening.  

 

 

 

 
Hands on Activity - Inserting Doors 

The Envisioneer catalog contains a wide variety of doors for you to insert, including 
hinged, bi-fold, pocket, sliding glass and garage doors. You can point and click to 
insert a door anywhere inside a wall, automatically center the door in the wall, or 
offset the door a specific distance from the end of the wall. 

Doors are inserted at floor level. You can raise or lower a door after you have inserted 
it if you need to. 

For You to Try– This exercise requires the use of Cadsoft Envisioneer 
In this exercise we will insert doors using the point-and-click method, Center on Wall 
option, and Insertion Offset option. 

1. File>Open. 

2. Select the file created earlier in the manual. 

3. Ensure the current location is the Ground Floor. 

 

The 
door 
swing 

The 
door  

The door opening 
and frame 
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4. Select Insert > Doors, or click the Doors button on the Building toolbar. 

5. In the catalog panel, select the Entry group and then the 36” Steel Door. 

6. In the drawing screen area, right click and select Center on Wall. 

7. Move your cursor onto the middle of the front exterior wall in the stud 
portion of the wall. The door swing will be illustrated swinging inside as 
depicted in the diagram below. 

 
8. Left click to center the door in the wall. 

9. In the catalog panel, select the French Doors group and the 60” Double 
French Door element. 

10. Move your cursor onto the drawing screen area, right click and select Enter 
Insertion Offset.  

NOTE: If you want to install the door a specific distance from the end of a wall, 
door or window use the Enter Insertion Offset tool.  When activated, as you 
move your cursor close to a wall a dimension will appear along the wall with 
the distance you specify. When it is in the correct position, left click to install the 
door. It will install exactly that distance away from the corner.  

11. Type 2’ and click OK. 

12. Move your cursor onto the rear exterior wall in the Dining Room close to the 
interior wall between the Dining Room and Kitchen. Left click when the 2’ 
dimension places the door exactly 2’ from the wall. 

 

 
 

13. In the Catalog Panel, select the 30” French Door. 

14. Move your cursor onto the drawing screen area, right click and choose 
Center on wall. 
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15. Place your cursor in the interior wall between the Office and the Front Hall. 
Left click to center it in the wall with the swing facing into the room. 

16. In the Catalog Panel, select the 32” 9-Lite Steel Door. 

17. Move your cursor onto the drawing screen area, right click and choose 
Center on wall. 

18. Place your cursor in the right exterior wall entering into the Mudroom. Left 
click to center the door in that wall. 

19. Choose the Hinged group and the 32” Hinged Door in the door list below. 

20. In the drawing screen area, right click and select Enter Insertion Offset. 

21. Type 6” and click OK. 

22. Move your cursor along the top interior wall of the Mudroom close the right 
exterior wall. Left click when the 6” dimension appears from the exterior 
wall. 

 

 
 

23. Right click and choose Finish. 

24. File>Save. 

Your model on the Ground Floor should now appear as the following diagram.   
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25. Continue on by inserting doors on the second floor plan, following the 
diagram and chart below.  

Remember to use the Center on wall and Enter Insertion Offset tools to place 
the doors. 

 

 

 

 
Flipping Door Swings 

Some of the doors inserted with the door opening facing a wall. We can easily flip the 
swing of doors. 

1. Click on the front entry door to select it. 

2. Right-click and select Flip Swing. The swing flips automatically. 

3. Flip any door swings as needed to match the diagram above. 

Flipping Door Openings 

Some of the bi-fold closet doors may need to be flipped around so that they open 
out instead of in. 

A Hinged 32” Hinged Door 

B  Bi-Fold 32” Bi-Fold Door 

A 

A 

A 

A 

A 

A 

B 
B 

A 

A 



 

| Materials and Methods  Page 41 of 59 

1. Click on a door that needs to be flipped. 

2. Right-click and select Flip Opening. The door flips automatically. 

3. Repeat for any other doors that need to be flipped. 

4. Select File > Save. 

 
Windows 
Simply stated,  

 

Depicting Windows in a Floor Plan 
When showing a window in a floor plan you show the size of the frame and the 
location of the glass and its orientation in the wall.  

 

 

 

 

 

 
 
Hands on Activity - Inserting Windows 

The Envisioneer catalog contains a wide variety of windows for you to insert, including 
fixed, casement, double casement, hopper, awning, sliding, double-hung, single-
hung, bay, bow and louvered windows. 

You can point and click to insert a window anywhere in a wall, automatically center 
the window on the wall, or offset the window a specific distance from the end of the 
wall. 

Windows are inserted at the Head Height defined for the building location (See the 
Introduction to Envisioneer section) you insert the window on. You can raise or lower 
a window after you have inserted it if you need to. 

For You to Try– This exercise requires the use of Cadsoft Envisioneer 
In this exercise we will insert windows using the point-and-click method, Center on 
Wall option, and Insertion Offset option. 

1. File>Open. 

2. Select the file created earlier in the manual. 

This line represents 
the glass in the 
window. 

This line represents 
the frame of the 
window. 
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3. Select Insert > Windows, or click the Windows button on the Building 
toolbar. 

4. In the catalog panel, select the Double Casement category, then select the 
4’-9” X 4' Double Casement Window.  

5. In the drawing area, right-click and select Enter Insertion Offset. 

6. Type 1’6” and click OK. 

7. Insert the 4 front windows 1’6” away from each of the corners as shown in the 
diagram below.  

 
 

8. In the catalog panel select the 3’5x3’ Double Casement window form the Double 
Casement category.  

9. In the drawing screen area, right click and select Enter Insertion Offset. 

10. Type 1’10” and click OK. 

11. Insert the window along the rear exterior wall as shown in the diagram 
below.  

 

 

 

 

 

 

 

12. In the Catalog panel select the Bay window group and the 6’-10” X 5’-6” 
Bay Window (2’ Side Windows). 

13. Move the cursor onto the drawing screen area and right click and select 
Center on Wall. 

14. Center the window in the rear window as shown in the diagram below. 
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15. In the lower left hand corner of the screen, switch locations to the second 
floor. 

 

16. Using the diagram and chart below, insert the second floor windows.  

 

 

A Double Casement 3’-5” X 4’-5” Double 
Casement Window 

Insertion offset of 
1’6”. 

B Double Casement 3’-5” X 4’-5” Double 
Casement Window 

Center on Wall 

C Double Casement 3’-5” X 3’ Double Casement 
Window 

Center on Wall 

 

 

 

 

 

 

 

 

 

 

 

 

 

17. Right click and choose Finish.  

18. File > Save.  

Openings 
An opening is a cutout in a wall of a specific shape, width and height. The opening 
can be used as a doorway, a smaller pass through or an art niche where the opening 
isn’t cut entirely through the wall.  

A A A A A 

B B 
C 
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The opening will not have a door or window hung in the space. It is just a clear 
opening cut in a wall.  

INSERT TEXT AND PICTURES HERE 

 

 

Depicting an Opening on a Floor Plan 
The general rule is that an architectural floor plan is visualized as being cut at approx. 
4 feet from the ground, so you draw it as if you are viewing the plan from 4 feet up. 
Anything you wouldn't see at that level, you would show dashed in. Use small dashes 
for items hidden below and longer dashes for items above. So if the wall opening is 
cut 4’ above the floor and isn’t a full opening show it as a dashed line. If it is a full 
height opening show it as continuous.  

 

 

 

Hands on Activity - Inserting Openings 
When inserting an opening in Envisioneer, you can either use the on-screen 
dimensions to position the opening in the wall, use the Center on Wall option to 
automatically center the opening on the wall, or use the Insertion Offset option to 
offset the opening a specific distance from the end of a wall. 

For You to Try– This exercise requires the use of Cadsoft Envisioneer 
In this exercise we will insert openings using the Center on Wall option, and Insertion 
Offset option. 

1. File>Open. 

2. Select the file created earlier in the manual. 

3. Select Insert > Openings, or click the Openings button on the 

A doorway 
opening is cut 
at the same 
head height as 
a door. 

A Pass thru 
opening allows 
you to see into 
another room 
like a window. 

A niche 
opening isn’t 
cut entirely 
through a wall 
and creates a 
focal point to 
display artwork. 

Dashed lines 
indicate the 
opening is below 
or above the 4’ 
level. 

Solid opening 
lines indicate 
the opening is 
visible from 4’. 
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Building toolbar. 

4. Select the Rectangular (Doorways) group and the 5’ X 6’-8” Rectangular 
Opening element. 

5. Move the cursor onto the drawing screen area and right click and select 
Center on Wall.  

6. Place the cursor in the wall between the Dining Room and Living Room. It 
will find the center of the wall. Left click to insert it.  

7. Right click and select Enter Insertion Offset. 

8. Type 2” and click OK. 

9. Place the cursor in the wall between the Living Room and Front Hall , as 
depicted by Opening A in the diagram below. Left click when the 
dimensional guide is 2” from the bottom of the interior wall. 

10. Move your cursor up to the top end of this same wall where it meets the rear 
exterior wall. Opening B in the diagram below. Left click to insert it 2” away 
from the top corner. 

11. Right click and choose Finish.  

12. File > Save. 

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

A 

B 
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Stairs 
INSERT TEXT AND PICTURES HERE 

 

Depicting Stairs on a Floor Plan 
INSERT TEXT 

 

 

 

Hands on Activity - Inserting Stairs 
When inserting a set of stairs in Envisioneer, you can do so with a single mouse click. If 
you place the staircase near a wall, the staircase will automatically snap to the wall. 
Once you have inserted a staircase, you can edit its size, style and geometry. 

For You to Try– This exercise requires the use of Cadsoft Envisioneer 
In this exercise we will insert a set of stairs on the Ground floor leading to the Second 
floor. 

1. File>Open. 

2. Select the Ground floor location, where you want to insert the base of the 
staircase. 

3. Select Insert > Stairs/Ramps, or click the Stairs/Ramps button on the 
Building toolbar. 

4. In the catalog, select the L - Shaped Stairs group and the 3' Wide L-Shaped 
Right Stairs, Notched Stringer staircase.  

5. Position the staircase just above the front hall opening leading to the Living 
Room and click to insert it.  
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TIP: You may need to turn off collision to place the stair inside the front hall. The 
stair, when first inserted, will be longer than the hall and therefore collide with 
the adjacent walls. By turning off collision Envisioneer will overlook this and you 
can then adjust the settings of the stairs to fit.  

6. Right-click and select Finish. 
7. Left click on the inserted stair to select it. 
8. Right click and select Properties. 
9. Click on the Riser Maximum edit box.  

The Riser Maximum value is determined by your local building codes. It dictates 
the maximum height of a riser in a set of stairs. The Riser Height option can not 
exceed the value set here. If the Overall Height divided by the Total steps 
exceeds the Riser maximum the Total steps will be adjusted. 

 

10. Type 8”. 
11. Click on the Total Steps edit box. Type 14. 

The Riser Height will adjust to accommodate the 14 stairs in a 9’ height. 

12. Click on the Layout tab. 
13. In the Layout Segments area, click on Stair 3, change the Number of Steps 

value to 3. 
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14. Click OK. 
15. File > Save. 

The stair will adjust to the new parameters set. 

Floors 
Typically in residential construction floors that sit above grade are constructed using 
a floor joist system. This framework will act like a platform and span the house from 
one exterior wall to the other. 

Floor Joist 

Manufactured Floor Joists 

Floor Slabs 

Rim Joist 

Floor Sheathing 

Finish Floor Material 
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Hands on Activity - Inserting Floors 

The Envisioneer catalog contains an extensive selection of framing members in 
various sizes and shapes that will aid you in creating a floor structure.  

When you create an enclosed room in Envisioneer it will automatically place a 
finished floor in the room. The floor will hug the perimeter of the room and every room 
in the model will have a separate floor. For presentation purposes this is perfect as you 
want to be able to quickly design and show a client their home with finish floor 
materials. For structural layouts another flooring system will have to be used that will 
match the floor joist layout and not the individual room layout.  

For You to Try– This exercise requires the use of Cadsoft Envisioneer 
In this exercise we will remove the automatic floor and replace it with a new floor 
that will match the structural floor system for the house.  

1. File>Open. 

2. Select the file created in chapter one and click OK. 

3. Ensure the Ground Floor is the current floor location.  

 

 

4. Select View>2D Designers View. 

In this view you can see the finish materials for the floor plan. The flooring 
materials become apparent for each room. 

5. Left click in the middle of the Mudroom to select the floor in that area. The 
edge will highlight green. The edge will hug the perimeter of the room. 

6. Right click and select Delete.  

Floor joist 

Floor joists 
are spaced 
at regular 
intervals 
apart. 
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7. The floor is removed.  Repeat for each room on the Ground floor. 

8. Select Insert> Floor>Floor by Picking Points. 

9. The Catalog panel to the right will update with your options. 

10. Select the Wood Flooring Group and the Hardwood Floor 1 in the Floors list 
below. 

11. Left click in the upper left corner of the exterior stud wall line as depicted in 
the diagram below. 

 

 

 

 

 

12. Moving the cursor to the right (the 0º direction) type 33’7” and press Enter. 

13. Move the cursor down (270º) and type 15’9” and press Enter. 

14. Move the cursor to the left (180º) and type 33’7” and press Enter. 

15. Right click and choose Finish. 

The floor is inserted. Now we will make a copy of for the area at the front of the 
house that also requires a floor system.  

16. Left click on the floor edge to select it. 

17. Right click and choose Duplicate. 

18. Holding down the left mouse button drag a copy of the floor system down 
(270º) as you are dragging the floor type 15’9” and press Enter. 

This will make a copy of the floor so the lower edge of the first floor is abutting 
the upper edge of the new floor. Now we need to install one last piece of 
flooring at the rear breakfast nook. 

Exterior corner 
of the stud wall 
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19. Select the Wood Flooring Group and the Hardwood Floor 1 in the Floors list 
below. 

20. Left click in the upper left corner of the exterior stud wall line as depicted in 
the diagram below. 

 

 

 

 

21. Moving the cursor to the right (the 0º direction) type 9’7” and press Enter. 

22. Move the cursor down (270º) and type 2’and press Enter. 

23. Move the cursor to the left (180º) and type 9’7” and press Enter. 

24. Right click and choose Finish. 

25. Repeat the process on the second floor location as well.  

Inserting a concrete slab in the Basement 

1. Change the floor location to the Foundation. 

 

 

 

 

2. Select View>2D Designer’s View. 

The finish materials are displayed. 

3. Left click on the inserted floor. 

4. Right click and choose Delete.  

5. Select Insert>Floors>Floors by Perimeter. 

6. In the Catalog Panel, select the Slabs group and the 4” Concrete Floor 
element. 

7. Left click inside the perimeter of the home. 

The floor slab is inserted. 
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8. Right click and choose Finish. 

9. File > Save. 

 

Ceilings 
 

INSERT CEILING TEXT HERE 

Hands on Activity – Ceilings 
When you use the ceiling command in Envisioneer, it has the option to place a ceiling 
in each room separately (Ceiling by Room), following the exterior perimeter walls 
(Ceiling by Perimeter) or place the ceiling using free form points (Ceiling by Picking 
Points). In this exercise will insert a ceiling in each room and then cut a hole in the 
ceiling to accommodate the stairs. 

For You to Try- This exercise requires the use of Cadsoft Envisioneer 
1. File >Open. 

2. Select the file that you have created previously using this text. Click OK. 

3. Set the current location to Ground Floor. 

 

 

4. Select Insert > Ceilings > Ceiling by Room, or activate the Ceilings 
flyout on the Building toolbar and select Ceiling by Room. 

5. In the catalog panel, select the 1/2” Drywall Ceiling in the Standard 
category. 

6. Click inside the rear left room in the house. A ceiling is automatically 
inserted in the room.  

7. Continue inserting ceilings in each room, then right-click and select Finish.  
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Roofs 
INSERT ROOF TEXT HERE 

Hands on Activity - Roofs 
Envisioneer offers two insertion methods for roofs: Roof by Perimeter and Roof by 
Picking Points.  

When you use the Roof by Perimeter tool it will look at all of the perimeter walls and 
automatically place a roof structure over them.  The walls and the roof become a 
cohesive unit that move and interact together. 

When you use the Roof by Picking Points option to insert a roof, you are freely picking 
points to define each roof corner. There is no tie between the roof and any walls that 
may be beneath it.  

Each option for inserting a roof has their strengths and flexibility and before you insert 
a roof you should determine where the roof structure will lie in accordance with the 
walls and therefore which method of roof insertion will best suit your needs.  

ROOF BY PERIMETER ROOF BY PICKING POINTS 

 
 

 

 
 
Hands on Activity – Roof by Perimeter 
When you use the Roof by Perimeter tool it will look at all of the perimeter walls and 
place a roof structure over them.  

Your walls therefore need to be in place and in a continuous formation.  

The 
overhang of 
the roof 
matches the 
outline of the 
model. 

The overhang 
of the roof was 
achieved by 
picking points 
not necessarily 
along the wall. 
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For You to Try- This exercise requires the use of Cadsoft Envisioneer 
1. File >Open. 

2. Select the file that you have created previously using this text. Click OK. 

3. Ensure the Building Location is set to the Second Floor. 

 

 

 

4. Select Insert > Roofs > Roof by Perimeter, or click the Roofs button on 
the Building toolbar and select Roof by Perimeter. 

5.     In the catalog, select the 4/12 Pitch Hip Roof, Asphalt Shingles from the 
Hip category.  

6.    Click anywhere inside the model. The roof is inserted automatically. 

 


